U
     T‚gw!  ã                	   @   s†  d Z ddlmZmZmZmZ ddlmZmZm	Z	 ddl
mZ G dd„ deƒZG dd„ deƒZG d	d
„ d
eƒZG dd„ deƒZe	eƒG dd„ dƒƒZe	eƒG dd„ dƒƒZe	eƒG dd„ dƒƒZe	eƒG dd„ dƒƒZe	eƒG dd„ dƒƒZe	eƒG dd„ dƒƒZe	eƒG dd„ dƒƒZe	eƒG dd„ dƒƒZeƒ eƒ eƒ eƒ eƒ eƒ eƒ eƒ dœZdd„ Zd d!„ Zd"d#„ Zd$d%„ Zd&d'„ Zd(d)„ Zd*S )+z
SSH key exchange handling.
é    )Úsha1Úsha256Úsha384Úsha512)Ú	AttributeÚ	InterfaceÚimplementer)Úerrorc                   @   s    e Zd ZdZedƒZedƒZdS )Ú_IKexAlgorithmzB
    An L{_IKexAlgorithm} describes a key exchange algorithm.
    z‹An L{int} giving the preference of the algorithm when negotiating key exchange. Algorithms with lower precedence values are more preferred.zqA callable hash algorithm constructor (e.g. C{hashlib.sha256}) suitable for use with this key exchange algorithm.N)Ú__name__Ú
__module__Ú__qualname__Ú__doc__r   Ú
preferenceÚhashProcessor© r   r   ú:/tmp/pip-unpacked-wheel-1_7di8ic/twisted/conch/ssh/_kex.pyr
      s   ÿÿr
   c                   @   s    e Zd ZdZedƒZedƒZdS )Ú_IFixedGroupKexAlgorithmzu
    An L{_IFixedGroupKexAlgorithm} describes a key exchange algorithm with a
    fixed prime / generator group.
    zdAn L{int} giving the prime number used in Diffie-Hellman key exchange, or L{None} if not applicable.z�An L{int} giving the generator number used in Diffie-Hellman key exchange, or L{None} if not applicable. (This is not related to Python generator functions.)N)r   r   r   r   r   ÚprimeÚ	generatorr   r   r   r   r   "   s   ÿÿr   c                   @   s   e Zd ZdZdS )Ú#_IEllipticCurveExchangeKexAlgorithmzž
    An L{_IEllipticCurveExchangeKexAlgorithm} describes a key exchange algorithm
    that uses an elliptic curve exchange between the client and server.
    N©r   r   r   r   r   r   r   r   r   4   s   r   c                   @   s   e Zd ZdZdS )Ú_IGroupExchangeKexAlgorithmzõ
    An L{_IGroupExchangeKexAlgorithm} describes a key exchange algorithm
    that uses group exchange between the client and server.

    A prime / generator group should be chosen at run time based on the
    requested size. See RFC 4419.
    Nr   r   r   r   r   r   ;   s   r   c                   @   s   e Zd ZdZdZeZdS )Ú_Curve25519SHA256z”
    Elliptic Curve Key Exchange using Curve25519 and SHA256. Defined in
    U{https://datatracker.ietf.org/doc/draft-ietf-curdle-ssh-curves/}.
    é   N©r   r   r   r   r   r   r   r   r   r   r   r   E   s   r   c                   @   s   e Zd ZdZdZeZdS )Ú_Curve25519SHA256LibSSHzN
    As L{_Curve25519SHA256}, but with a pre-standardized algorithm name.
    é   Nr   r   r   r   r   r   P   s   r   c                   @   s   e Zd ZdZdZeZdS )Ú_ECDH256aX  
    Elliptic Curve Key Exchange with SHA-256 as HASH. Defined in
    RFC 5656.

    Note that C{ecdh-sha2-nistp256} takes priority over nistp384 or nistp512.
    This is the same priority from OpenSSH.

    C{ecdh-sha2-nistp256} is considered preety good cryptography.
    If you need something better consider using C{curve25519-sha256}.
    é   Nr   r   r   r   r   r   Z   s   r   c                   @   s   e Zd ZdZdZeZdS )Ú_ECDH384zT
    Elliptic Curve Key Exchange with SHA-384 as HASH. Defined in
    RFC 5656.
    é   N)r   r   r   r   r   r   r   r   r   r   r   r    k   s   r    c                   @   s   e Zd ZdZdZeZdS )Ú_ECDH512zT
    Elliptic Curve Key Exchange with SHA-512 as HASH. Defined in
    RFC 5656.
    é   N)r   r   r   r   r   r   r   r   r   r   r   r"   v   s   r"   c                   @   s   e Zd ZdZdZeZdS )Ú_DHGroupExchangeSHA256zc
    Diffie-Hellman Group and Key Exchange with SHA-256 as HASH. Defined in
    RFC 4419, 4.2.
    é   Nr   r   r   r   r   r$   �   s   r$   c                   @   s   e Zd ZdZdZeZdS )Ú_DHGroupExchangeSHA1za
    Diffie-Hellman Group and Key Exchange with SHA-1 as HASH. Defined in
    RFC 4419, 4.1.
    é   N)r   r   r   r   r   r   r   r   r   r   r   r&   Œ   s   r&   c                   @   s$   e Zd ZdZdZeZedƒZdZ	dS )Ú_DHGroup14SHA1z�
    Diffie-Hellman key exchange with SHA-1 as HASH and Oakley Group 14
    (2048-bit MODP Group). Defined in RFC 4253, 8.2.
    é   Ai  32317006071311007300338913926423828248817941241140239112842009751400741706634354222619689417363569347117901737909704191754605873209195028853758986185622153212175412514901774520270235796078236248884246189477587641105928646099411723245426622522193230540919037680524235519125679715870117001058055877651038861847280257976054903569732561526167081339361799541336476559160368317896729073178384589680639671900977202194168647225871031411336429319536193471636533209717077448227988588565369208645296636077250268955505928362751121174096972998068410554359584866583291642136218231078990999448652468262416972035911852507045361090559r   N)
r   r   r   r   r   r   r   Úintr   r   r   r   r   r   r(   —   s   ÿr(   )ó   curve25519-sha256s   curve25519-sha256@libssh.orgs$   diffie-hellman-group-exchange-sha256s"   diffie-hellman-group-exchange-sha1s   diffie-hellman-group14-sha1s   ecdh-sha2-nistp256s   ecdh-sha2-nistp384s   ecdh-sha2-nistp521c                 C   s    | t krt d| › �¡‚t |  S )aY  
    Get a description of a named key exchange algorithm.

    @param kexAlgorithm: The key exchange algorithm name.
    @type kexAlgorithm: L{bytes}

    @return: A description of the key exchange algorithm named by
        C{kexAlgorithm}.
    @rtype: L{_IKexAlgorithm}

    @raises ConchError: if the key exchange algorithm is not found.
    z$Unsupported key exchange algorithm: )Ú_kexAlgorithmsr	   Z
ConchError©ÚkexAlgorithmr   r   r   ÚgetKex¾   s    r/   c                 C   s   t  t| ƒ¡S )a  
    Returns C{True} if C{kexAlgorithm} is an elliptic curve.

    @param kexAlgorithm: The key exchange algorithm name.
    @type kexAlgorithm: C{str}

    @return: C{True} if C{kexAlgorithm} is an elliptic curve,
        otherwise C{False}.
    @rtype: C{bool}
    )r   Ú
providedByr/   r-   r   r   r   ÚisEllipticCurveÐ   s    r1   c                 C   s   t  t| ƒ¡S )a+  
    Returns C{True} if C{kexAlgorithm} has a fixed prime / generator group.

    @param kexAlgorithm: The key exchange algorithm name.
    @type kexAlgorithm: L{bytes}

    @return: C{True} if C{kexAlgorithm} has a fixed prime / generator group,
        otherwise C{False}.
    @rtype: L{bool}
    )r   r0   r/   r-   r   r   r   ÚisFixedGroupÞ   s    r2   c                 C   s   t | ƒ}|jS )a  
    Get the hash algorithm callable to use in key exchange.

    @param kexAlgorithm: The key exchange algorithm name.
    @type kexAlgorithm: L{bytes}

    @return: A callable hash algorithm constructor (e.g. C{hashlib.sha256}).
    @rtype: C{callable}
    )r/   r   ©r.   Zkexr   r   r   ÚgetHashProcessorì   s    
r4   c                 C   s   t | ƒ}|j|jfS )zù
    Get the generator and the prime to use in key exchange.

    @param kexAlgorithm: The key exchange algorithm name.
    @type kexAlgorithm: L{bytes}

    @return: A L{tuple} containing L{int} generator and L{int} prime.
    @rtype: L{tuple}
    )r/   r   r   r3   r   r   r   ÚgetDHGeneratorAndPrimeú   s    
r5   c                     s¦   ddl m}  ddlm} ddlm} | ƒ }t ¡ ‰ tˆ ƒD ]V}| 	d¡rj| 
dd¡}| | ¡ || ¡}n| 	d¡r~| ¡ }nd}|s:ˆ  |¡ q:tˆ ‡ fd	d
„d�S )z½
    Get a list of supported key exchange algorithm names in order of
    preference.

    @return: A C{list} of supported key exchange algorithm names.
    @rtype: C{list} of L{bytes}
    r   )Údefault_backend)Úec)Ú_curveTables   ecdhs   ecdsar+   Tc                    s
   ˆ |  j S )N)r   r-   ©ZkexAlgorithmsr   r   Ú<lambda>$  ó    z*getSupportedKeyExchanges.<locals>.<lambda>)Úkey)Zcryptography.hazmat.backendsr6   Z)cryptography.hazmat.primitives.asymmetricr7   Ztwisted.conch.ssh.keysr8   r,   ÚcopyÚlistÚ
startswithÚreplaceZ+elliptic_curve_exchange_algorithm_supportedZECDHZx25519_supportedÚpopÚsorted)r6   r7   r8   ÚbackendZkeyAlgorithmZkeyAlgorithmDsaÚ	supportedr   r9   r   ÚgetSupportedKeyExchanges  s*    
 ÿ

 
ÿrE   N)r   Úhashlibr   r   r   r   Zzope.interfacer   r   r   Ztwisted.conchr	   r
   r   r   r   r   r   r   r    r"   r$   r&   r(   r,   r/   r1   r2   r4   r5   rE   r   r   r   r   Ú<module>   sL   

	



ø