ó
    Ö›‘hÁ	  ã                   óŒ  • S r SSKrSSKrSSKJr  SSKJrJr   " S S\R                  5      r	 " S S\R                  5      r
\" \R                  5       " S	 S
\R                  5      5       r " S S\R                  5      r " S S\R                  5      r " S S\R                  5      r " S S\R                  5      r/ SQrg)zzImplement standard (and unused) TCP protocols.

These protocols are either provided by inetd, or are not provided at all.
é    N)Úimplementer)Ú
interfacesÚprotocolc                   ó   • \ rS rSrSrS rSrg)ÚEchoé   z;
As soon as any data is received, write it back (RFC 862).
c                 ó:   • U R                   R                  U5        g ©N)Ú	transportÚwrite©ÚselfÚdatas     ÚZC:\Users\psant\Downloads\Noiseback\school\venv\Lib\site-packages\twisted/protocols/wire.pyÚdataReceivedÚEcho.dataReceived   s   € Ø�‰×Ñ˜TÕ"ó    © N©Ú__name__Ú
__module__Ú__qualname__Ú__firstlineno__Ú__doc__r   Ú__static_attributes__r   r   r   r   r      s   † ñõ#r   r   c                   ó   • \ rS rSrSrS rSrg)ÚDiscardé   z&
Discard any received data (RFC 863).
c                 ó   • g r
   r   r   s     r   r   ÚDiscard.dataReceived    s   € àr   r   Nr   r   r   r   r   r      s   † ñõr   r   c                   ó4   • \ rS rSrSrSrS rS rS rS r	Sr
g	)
ÚChargené%   z%
Generate repeating noise (RFC 864).
sG   @ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz{|}~ !"#$%&?c                 ó<   • U R                   R                  U S5        g )Nr   )r   ÚregisterProducer©r   s    r   ÚconnectionMadeÚChargen.connectionMade-   s   € Ø�‰×'Ñ'¨¨aÕ0r   c                 óN   • U R                   R                  U R                  5        g r
   )r   r   Únoiser&   s    r   ÚresumeProducingÚChargen.resumeProducing0   s   € Ø�‰×Ñ˜TŸZ™ZÕ(r   c                 ó   • g r
   r   r&   s    r   ÚpauseProducingÚChargen.pauseProducing3   ó   € Ør   c                 ó   • g r
   r   r&   s    r   ÚstopProducingÚChargen.stopProducing6   r0   r   r   N)r   r   r   r   r   r*   r'   r+   r.   r2   r   r   r   r   r"   r"   %   s#   † ñð X€Eò1ò)òõr   r"   c                   ó$   • \ rS rSrSrS rS rSrg)ÚQOTDé:   z&
Return a quote of the day (RFC 865).
c                 óŠ   • U R                   R                  U R                  5       5        U R                   R                  5         g r
   )r   r   ÚgetQuoteÚloseConnectionr&   s    r   r'   ÚQOTD.connectionMade?   ó*   € Ø�‰×Ñ˜TŸ]™]›_Ô-Ø�‰×%Ñ%Õ'r   c                 ó   • g)z2
Return a quote. May be overrriden in subclasses.
s'   An apple a day keeps the doctor away.
r   r&   s    r   r8   ÚQOTD.getQuoteC   s   € ð <r   r   N)r   r   r   r   r   r'   r8   r   r   r   r   r5   r5   :   s   † ñò(õ<r   r5   c                   ó$   • \ rS rSrSrS rS rSrg)ÚWhoéJ   z'
Return list of active users (RFC 866)
c                 óŠ   • U R                   R                  U R                  5       5        U R                   R                  5         g r
   )r   r   ÚgetUsersr9   r&   s    r   r'   ÚWho.connectionMadeO   r;   r   c                 ó   • g)z.
Return active users. Override in subclasses.
s   root
r   r&   s    r   rB   ÚWho.getUsersS   s   € ð r   r   N)r   r   r   r   r   r'   rB   r   r   r   r   r?   r?   J   s   † ñò(õr   r?   c                   ó   • \ rS rSrSrS rSrg)ÚDaytimeéZ   z0
Send back the daytime in ASCII form (RFC 867).
c                 óê   • U R                   R                  [        R                  " [        R                  " [        R                  " 5       5      5      S-   5        U R                   R                  5         g )Ns   
)r   r   ÚtimeÚasctimeÚgmtimer9   r&   s    r   r'   ÚDaytime.connectionMade_   sA   € Ø�‰×ÑœTŸ\š\¬$¯+ª+´d·i²i³kÓ*BÓCÀgÑMÔNØ�‰×%Ñ%Õ'r   r   N©r   r   r   r   r   r'   r   r   r   r   rG   rG   Z   s   † ñõ(r   rG   c                   ó   • \ rS rSrSrS rSrg)ÚTimeéd   z8
Send back the time in machine readable form (RFC 868).
c                 óÔ   • [         R                  " S[        [        R                  " 5       5      5      nU R                  R                  U5        U R                  R                  5         g )Nz!i)ÚstructÚpackÚintrJ   r   r   r9   )r   Úresults     r   r'   ÚTime.connectionMadei   s?   € ä—’˜T¤3¤t§y¢y£{Ó#3Ó4ˆØ�‰×Ñ˜VÔ$Ø�‰×%Ñ%Õ'r   r   NrN   r   r   r   rP   rP   d   s   † ñõ(r   rP   )r   r   r"   r5   r?   rG   rP   )r   rS   rJ   Úzope.interfacer   Útwisted.internetr   r   ÚProtocolr   r   Ú	IProducerr"   r5   r?   rG   rP   Ú__all__r   r   r   Ú<module>r]      s¸   ðñó Û å &ç 1ô#ˆ8×Ñô #ôˆh×Ñô ñ ˆZ×!Ñ!Ó"ôˆh×Ñó ó #ðô(<ˆ8×Ñô <ô ˆ(×
Ñ
ô ô (ˆh×Ñô (ô	(ˆ8×Ñô 	(ò K�r   